Node

Couldn't start Appium REST http interface listener. Requested port is already in use. Please make sure there's no other instance of Appium running already.

環境 MacOSX 10.11 nodebrew 5.0.0 npm 3.3.6 Node 5.0.0 Appium 1.4.13 現象 Appium GUI アプリで Launch したところ、以下のエラーが走り起動しなかった。 Couldn't start Appium REST http interface listener. Requested port is already in use. Please…

RSpecをAppiumで書く

環境 MacOSX 10.11 nodebrew 5.0.0 npm 3.3.6 Node 5.0.0 Appium 1.4.13 更新日時: 2015/11/05 事前準備: nodebrewによるnpmのインストール hrt0kmt.hatenablog.com Appiumのインストール % npm install -g appium // sudoを用いる場合は sudo npm install -…

nodebrewの使い方まとめ

環境 MacOSX 10.11 nodebrew 5.0.0 npm 3.3.6 Node 5.0.0 既存のNode.jsの削除 こちらのcurl -ks https://gist.githubusercontent.com/nicerobot/2697848/raw/uninstall-node.shのshで既存のNode.jsを削除。 % curl -ks https://gist.githubusercontent.com/…

UI test automatically by using Selenium-WebDriver for Acceptance Testing

Environment MacOSX Yosemite Windows8.1 selenium-webdriver 2.46.2 Ruby 2.0.0 capybara 2.4.4 cucumber 2.0.0 turnip 1.3.0 rspec 3.3.0 pry-byebug 3.1.0 rubygems-update 2.4.8 Python 2.7.10 Case of using Ruby 1. Install gem Refer from this 2. In…

sudo: npm: command not found

seleniumをインストールしようとしたところ、command not foundと表示されてしまいました。 npmをインストールしなくてはならないようです。 % sudo npm -g install selenium-webdriver sudo: npm: command not found % sudo port install npm ---> Computin…

node.jsを入れる macports

以下のコマンドでインストールできます。 $ sudo port install nodejs node.jsをインストールする前にselfupdateをして、パッケージを最新にしておきましょう。 $ sudo port selfupdate $ sudo port upgrade outdated $ sudo port -u uninstall その後、node…