check gem command

hrt0kmt.hatenablog.com

check ruby version

% bundle exec ruby -v
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-darwin14]


check rbenv version

% bundle exec rbenv versions
  system
* 2.2.2 (set by /Users/hrt0kmt/.rbenv/version)


check environment

% bundle exec gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 2.4.5
  - RUBY VERSION: 2.2.2 (2015-04-13 patchlevel 95) [x86_64-darwin14]
  - INSTALLATION DIRECTORY: /Users/hrt0kmt/capybara_pj/example/vendor/bundle/ruby/2.2.0
  - RUBY EXECUTABLE: /Users/hrt0kmt/.rbenv/versions/2.2.2/bin/ruby
  - EXECUTABLE DIRECTORY: /Users/hrt0kmt/capybara_pj/example/vendor/bundle/ruby/2.2.0/bin
  - SPEC CACHE DIRECTORY: /Users/hrt0kmt/.gem/specs
  - SYSTEM CONFIGURATION DIRECTORY: /Users/hrt0kmt/.rbenv/versions/2.2.2/etc
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-darwin-14
  - GEM PATHS:
     - /Users/hrt0kmt/capybara_pj/example/vendor/bundle/ruby/2.2.0
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
     - "gem" => "--user-install"
     - :sources => ["http://gems.rubyforge.org/", "http://gemcutter.org"]
     - :benchmark => false


check installed gem package

% bundle exec gem list

*** LOCAL GEMS ***

actionmailer (4.1.1)
actionpack (4.1.1)
actionview (4.1.1)
activemodel (4.1.1)
activerecord (4.1.1)
activesupport (4.1.1)
arel (5.0.1.20140414130214)
binding_of_caller (0.7.2)
builder (3.2.2)
bundler (1.10.6)
byebug (5.0.0)
capybara (2.4.4)
childprocess (0.5.6)
cliver (0.3.2)
coderay (1.1.0)
coffee-rails (4.0.1)
coffee-script (2.4.1)
coffee-script-source (1.9.1.1)
columnize (0.9.0)
database_cleaner (1.4.1)
debug_inspector (0.0.2)
diff-lcs (1.2.5)
erubis (2.7.0)
execjs (2.5.2)
factory_girl (4.5.0)
factory_girl_rails (4.5.0)