warning: Insecure world writable dir /usr/local/bin in PATH, mode 040777

事象

pod install を行った時に Insecureエラーが表示されてしまう。


エラー内容

/Users/okamoto/.gem/ruby/2.2.0/gems/cocoapods-0.39.0/lib/cocoapods/command.rb:129: warning: Insecure world writable dir /usr/local/bin in PATH, mode 040777
Updating local specs repositories


対策

sudo 権限でmodeを変更する。

% sudo chmod go-w /usr/local/bin
% sudo chmod go-w /usr/local

go-wgroupotherswrite する権限を消すよう指定している。


参考